Psychobike banner
1 - 17 of 17 Posts

· Registered
Joined
·
80 Posts
Discussion Starter · #1 ·
I put on a full exhaust brocks shortmeg with the pc3 and now runs great until I hit the rev limiter then the FI light comes on with the red light flashing goes away when you cycle the key... I did the brocks FI light mod for the K5 cut a wire by my ecu....
 

· Registered
Joined
·
80 Posts
Discussion Starter · #3 ·
ran it again tonight and the FI light would come on in second gear 11k rpm every run and would start bouncing on 11k like i'm on the limiter... Do you think I should hook up the wire I cut... I know its the right wire checked about 10 times before I cut it haha ... maybe try disconnect the pc3???
 

· Registered
Joined
·
327 Posts
are you running a air filter? where you live at i have a used pcIIIusb to swap in to see if the box is the prob the cut wire is for the exhaust cables and servo motor nothing to do with pcIII but i thought the wire was black and brown that gets cut i didnt cut a red one on my k5
 

· Registered
Joined
·
80 Posts
Discussion Starter · #12 ·
Yeah I'm running a bmc race filter, I live on Maui so I dont know about that pc swap but thanks for the offer!!! Yeah I cut the black wire that mod was easy :buttrock: ... I called power commander today and he thought it was a problem with my duty cycle I was telling him everything you guys said :beer: he was gonna send me some software to fix it but never got anything yet hope he didnt forget!!
 
1 - 17 of 17 Posts
Top