Psychobike banner
1 - 11 of 11 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
IM HAVING TROUBLE WITH THE TPS STAYING IN TUNED ON MY 01 GSXR 1000. THE BIKE RUNS GOOD UNTIL 8000 RPMS AND THEN BEGINS TO BREAK OUT. WOULD THIS BE CAUSED BY THE TPS. ALSO IS THE TPS SUPPOSED TO CHANGE POSITIONS WHEN REVED UP AND IS THERE A WAY TO TEST THE TPS BEFORE BUYING A NEW ONE.
 

·
Premium Member
Joined
·
1,656 Posts
with key on, ign off, put a volt meter on it. As you twist the throttle, it should go from 0-5 volts (maybe 4.8ish) at wot
 

·
Registered
Joined
·
303 Posts
What makes you think this is even caused by the tps? I'd have to say your part throttle riding would be terrible if there was something wrong with the TPS. You can test it as described.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
The only reason i think it is the TPS is because when it started acting up we checked it and it wasn't in the middle position and when you adjust it gets better for a little while and then messes up again, but it hasn't gotten back to 100% since it started acting up. What else do i need to check. The only other thing i have checked is the spark plugs and ran some lucas fuel injector cleaner in it.
 

·
Registered
Joined
·
1,311 Posts
The only reason i think it is the TPS is because when it started acting up we checked it and it wasn't in the middle position and when you adjust it gets better for a little while and then messes up again, but it hasn't gotten back to 100% since it started acting up. What else do i need to check. The only other thing i have checked is the spark plugs and ran some lucas fuel injector cleaner in it.


Ive never seen one stay in the middle. ITs always moving around. Its a fuel issue. Either the line is pinched. ( if your still using the stock line remove it asap. Just use a rubber hose and two hose clamps. 1/4 high pressure fuel line from autozone works great. ) Its either pinched or the fuel pump is going out.


ALso as a last resort remove the secondary throttle blades and make a test run. Could be the servo motor not letting it them open.
 

·
Registered
Joined
·
622 Posts
Ive never seen one stay in the middle. ITs always moving around. Its a fuel issue. Either the line is pinched. ( if your still using the stock line remove it asap. Just use a rubber hose and two hose clamps. 1/4 high pressure fuel line from autozone works great. ) Its either pinched or the fuel pump is going out.


ALso as a last resort remove the secondary throttle blades and make a test run. Could be the servo motor not letting it them open.
Check the fuel pump. Ive run into that problem before. The screen could have trash in it.
 

·
Registered
Joined
·
2 Posts
I change my fuel pump my fuel regulator my starter alternator fuel lines high pressure filter and I just got a F1 code and when I connected it said c14 but he just it just my throttle sensor now he's saying my throttle sensor is bad orTPS how do I know it is bad
 
1 - 11 of 11 Posts
Top